What’s Vulnerable › Vulnerabilities
CVE-2021-24436: W3 Total Cache < 2.1.4 - Reflected XSS in Extensions Page (Attribute Context)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-19 · updated 2026-06-17
- Weakness: CWE-79
Description
The W3 Total Cache WordPress plugin before 2.1.4 was vulnerable to a reflected Cross-Site Scripting (XSS) security vulnerability within the "extension" parameter in the Extensions dashboard, which is output in an attribute without being escaped first. This could allow an attacker, who can convince an authenticated admin into clicking a link, to run malicious JavaScript within the user's web browser, which could lead to full site compromise.
Affected products
- boldgrid W3 Total Cache: before 2.1.4 — fixed in 2.1.4
How to fix
Upgrade to a fixed version: boldgrid W3 Total Cache 2.1.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/05988ebb-7378-4a3a-9d2d-30f8f58fe9ef
- https://wpscan.com/vulnerability/05988ebb-7378-4a3a-9d2d-30f8f58fe9ef
Get alerted when CVE-2021-24436 or the next vulnerability affects your stack