What’s Vulnerable › Vulnerabilities
CVE-2021-24442: Poll, Survey, Questionnaire and Voting system < 1.5.3 - Unauthenticated Blind SQL Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 46.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-12 · updated 2026-06-17
- Weakness: CWE-89
Description
The Poll, Survey, Questionnaire and Voting system WordPress plugin before 1.5.3 did not sanitise, escape or validate the date_answers[] POST parameter before using it in a SQL statement when sending a Poll result, allowing unauthenticated users to perform SQL Injection attacks
Affected products
- wpdevart Poll, Survey, Questionnaire and Voting system (WordPress plugin): before 1.5.3 — fixed in 1.5.3
How to fix
Upgrade to a fixed version: wpdevart Poll, Survey, Questionnaire and Voting system (WordPress plugin) 1.5.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/7376666e-9b2a-4239-b11f-8544435b444a
- https://www.in-spired.xyz/wpdevart-polls-blind-sql-injection/
- https://wpscan.com/vulnerability/7376666e-9b2a-4239-b11f-8544435b444a
- https://www.in-spired.xyz/wpdevart-polls-blind-sql-injection/
Get alerted when CVE-2021-24442 or the next vulnerability affects your stack