What’s Vulnerable › Vulnerabilities
CVE-2021-24443: Youzify < 1.0.7 - Stored Cross-Site Scripting via Biography
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The About Me widget of the Youzify – BuddyPress Community, User Profile, Social Network & Membership WordPress plugin before 1.0.7 does not properly sanitise its Biography field, allowing any authenticated user to set Cross-Site Scripting payloads in it, which will be executed when viewing the affected user profile. This could allow a low privilege user to gain unauthorised access to the admin side of the blog by targeting an admin, inducing them to view their profile with a malicious payload adding a rogue account for example.
Affected products
- Youzify – BuddyPress Community, User Profile, Social Network & Membership Plugin for WordPress: before 1.0.7 — fixed in 1.0.7
How to fix
Upgrade to a fixed version: Youzify – BuddyPress Community, User Profile, Social Network & Membership Plugin for WordPress 1.0.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a4432acd-df49-4a4f-8184-b55cdd5d4d34
- https://wpscan.com/vulnerability/a4432acd-df49-4a4f-8184-b55cdd5d4d34
Get alerted when CVE-2021-24443 or the next vulnerability affects your stack