What’s Vulnerable › Vulnerabilities
CVE-2021-24444: TaxoPress < 3.0.7.2 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The TaxoPress – Create and Manage Taxonomies, Tags, Categories WordPress plugin before 3.0.7.2 does not sanitise its Taxonomy description field, allowing high privilege users to set JavaScript payload in them even when the unfiltered_html capability is disallowed, leading to an authenticated Stored Cross-Site Scripting issue.
Affected products
- TaxoPress: before 3.0.7.2 — fixed in 3.0.7.2
How to fix
Upgrade to a fixed version: TaxoPress 3.0.7.2. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/164604/WordPress-TaxoPress-3.0.7.1-Cross-Site-Scripting.html
- https://wpscan.com/vulnerability/a31321fe-adc6-4480-a220-35aedca52b8b
- http://packetstormsecurity.com/files/164604/WordPress-TaxoPress-3.0.7.1-Cross-Site-Scripting.html
- https://wpscan.com/vulnerability/a31321fe-adc6-4480-a220-35aedca52b8b
Get alerted when CVE-2021-24444 or the next vulnerability affects your stack