What’s Vulnerable › Vulnerabilities
CVE-2021-24454: YOP Poll < 6.2.8 - Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-12 · updated 2026-06-17
- Weakness: CWE-79
Description
In the YOP Poll WordPress plugin before 6.2.8, when a pool is created with the options "Allow other answers", "Display other answers in the result list" and "Show results", it can lead to Stored Cross-Site Scripting issues as the 'Other' answer is not sanitised before being output in the page. The execution of the XSS payload depends on the 'Show results' option selected, which could be before or after sending the vote for example.
Affected products
- YOP Poll: before 6.2.8 — fixed in 6.2.8
How to fix
Upgrade to a fixed version: YOP Poll 6.2.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/48ade7a5-5abb-4267-b9b6-13e31e1b3e91
- https://www.in-spired.xyz/discovering-wordpress-plugin-yop-polls-v6-2-7-stored-xss/
- https://wpscan.com/vulnerability/48ade7a5-5abb-4267-b9b6-13e31e1b3e91
- https://www.in-spired.xyz/discovering-wordpress-plugin-yop-polls-v6-2-7-stored-xss/
Get alerted when CVE-2021-24454 or the next vulnerability affects your stack