What’s Vulnerable › Vulnerabilities
CVE-2021-24455: Tutor LMS < 1.9.2 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Tutor LMS – eLearning and online course solution WordPress plugin before 1.9.2 did not escape the Summary field of Announcements (when outputting it in an attribute), which can be created by users as low as Tutor Instructor. This lead to a Stored Cross-Site Scripting issue, which is triggered when viewing the Announcements list, and could result in privilege escalation when viewed by an admin.
Affected products
- themeum Tutor LMS – eLearning and online course solution: before 1.9.2 — fixed in 1.9.2
How to fix
Upgrade to a fixed version: themeum Tutor LMS – eLearning and online course solution 1.9.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9ef14cf1-1e04-4125-a296-9aa5388612f9
- https://wpscan.com/vulnerability/9ef14cf1-1e04-4125-a296-9aa5388612f9
Get alerted when CVE-2021-24455 or the next vulnerability affects your stack