What’s Vulnerable › Vulnerabilities
CVE-2021-24467: Leaflet Map < 3.0.0 - Arbitrary Settings Update via CSRF Leading to Stored XSS
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The Leaflet Map WordPress plugin before 3.0.0 does not verify the CSRF nonce when saving its settings, which allows attackers to make a logged in admin update the settings via a Cross-Site Request Forgery attack. This could lead to Cross-Site Scripting issues by either changing the URL of the JavaScript library being used, or using malicious attributions which will be executed in all page with an embed map from the plugin
Affected products
- Leaflet Map Project Leaflet Map: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: Leaflet Map Project Leaflet Map 3.0.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ac32d265-066e-49ec-9042-3145cd99e2e8
- https://wpscan.com/vulnerability/ac32d265-066e-49ec-9042-3145cd99e2e8
Get alerted when CVE-2021-24467 or the next vulnerability affects your stack