What’s Vulnerable › Vulnerabilities
CVE-2021-24468: Leaflet Map < 3.0.0 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Leaflet Map WordPress plugin before 3.0.0 does not escape some shortcode attributes before they are used in JavaScript code or HTML, which could allow users with a role as low as Contributors to exploit stored XSS issues
Affected products
- bozdoz Leaflet Map: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: bozdoz Leaflet Map 3.0.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/4b7c61da-952c-492a-8ce6-3c2126942a7c
- https://wpscan.com/vulnerability/4b7c61da-952c-492a-8ce6-3c2126942a7c
Get alerted when CVE-2021-24468 or the next vulnerability affects your stack