What’s Vulnerable › Vulnerabilities
CVE-2021-24471: YouTube Embed < 5.2.2 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The YouTube Embed WordPress plugin before 5.2.2 does not validate, escape or sanitise some of its shortcode attributes, leading to Stored XSS issues by 1. using w, h, controls, cc_lang, color, language, start, stop, or style parameter of youtube shortcode, 2. by using style, class, rel, target, width, height, or alt parameter of youtube_thumb shortcode, or 3. by embedding a video whose title or description contains XSS payload (if API key is configured).
Affected products
- YouTube Embed: before 5.2.2 — fixed in 5.2.2
How to fix
Upgrade to a fixed version: YouTube Embed 5.2.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a8ccb09a-9f8c-448f-b2d0-9b01c3a748ac
- https://wpscan.com/vulnerability/a8ccb09a-9f8c-448f-b2d0-9b01c3a748ac
Get alerted when CVE-2021-24471 or the next vulnerability affects your stack