What’s Vulnerable › Vulnerabilities
CVE-2021-24472: Onair2 < 3.9.9.2 & KenthaRadio < 2.0.2 - Unauthenticated RFI and SSRF
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 56.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-02 · updated 2026-06-17
- Weakness: CWE-918
Description
The OnAir2 WordPress theme before 3.9.9.2 and QT KenthaRadio WordPress plugin before 2.0.2 have exposed proxy functionality to unauthenticated users, sending requests to this proxy functionality will have the web server fetch and display the content from any URI, this would allow for SSRF (Server Side Request Forgery) and RFI (Remote File Inclusion) vulnerabilities on the website.
Affected products
- QantumThemes KenthaRadio: before 2.0.2 — fixed in 2.0.2
- QantumThemes OnAir2: before 3.9.9.2 — fixed in 3.9.9.2
How to fix
Upgrade to a fixed version: QantumThemes KenthaRadio 2.0.2; QantumThemes OnAir2 3.9.9.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/17591ac5-88fa-4cae-a61a-4dcf5dc0b72a
- https://wpscan.com/vulnerability/17591ac5-88fa-4cae-a61a-4dcf5dc0b72a
Get alerted when CVE-2021-24472 or the next vulnerability affects your stack