What’s Vulnerable › Vulnerabilities
CVE-2021-24483: Poll Maker < 3.2.1 - Authenticated Blind SQL Injections
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-02 · updated 2026-06-17
- Weakness: CWE-89
Description
The get_poll_categories(), get_polls() and get_reports() functions in the Poll Maker WordPress plugin before 3.2.1 did not use whitelist or validate the orderby parameter before using it in SQL statements passed to the get_results() DB calls, leading to SQL injection issues in the admin dashboard
Affected products
- Ays Pro Poll Maker: before 3.2.1 — fixed in 3.2.1
How to fix
Upgrade to a fixed version: Ays Pro Poll Maker 3.2.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0dc931c6-1fce-4d70-a658-a4bbab10dab3
- https://wpscan.com/vulnerability/0dc931c6-1fce-4d70-a658-a4bbab10dab3
Get alerted when CVE-2021-24483 or the next vulnerability affects your stack