What’s Vulnerable › Vulnerabilities
CVE-2021-24485: Special Text Boxes < 5.9.110 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Special Text Boxes WordPress plugin before 5.9.110 does not sanitise or escape some of its settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed.
Affected products
- Special Text Boxes: before 5.9.110 — fixed in 5.9.110
How to fix
Upgrade to a fixed version: Special Text Boxes 5.9.110. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/4a6b278a-4c11-4624-86bf-754212979643
- https://wpscan.com/vulnerability/4a6b278a-4c11-4624-86bf-754212979643
Get alerted when CVE-2021-24485 or the next vulnerability affects your stack