What’s Vulnerable › Vulnerabilities
CVE-2021-24489: Request a Quote < 2.3.9 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Request a Quote WordPress plugin before 2.3.9 does not sanitise, validate or escape some of its settings in the admin dashboard, leading to authenticated Stored Cross-Site Scripting issues even when the unfiltered_html capability is disallowed.
Affected products
- Request a Quote: before 2.3.5 — fixed in 2.3.5
How to fix
Upgrade to a fixed version: Request a Quote 2.3.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/36e8efe8-b29f-4c9e-9dd5-3e317aa43e0c
- https://wpscan.com/vulnerability/36e8efe8-b29f-4c9e-9dd5-3e317aa43e0c
Get alerted when CVE-2021-24489 or the next vulnerability affects your stack