What’s Vulnerable › Vulnerabilities
CVE-2021-24495: Marmoset Viewer < 1.9.3 - Reflected Cross Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The Marmoset Viewer WordPress plugin before 1.9.3 does not property sanitize, validate or escape the 'id' parameter before outputting back in the page, leading to a reflected Cross-Site Scripting issue.
Affected products
- Marmoset Viewer: before 1.9.3 — fixed in 1.9.3
How to fix
Upgrade to a fixed version: Marmoset Viewer 1.9.3. Check the vendor advisory for mitigations.
References
- https://johnjhacking.com/blog/cve-2021-24495-improper-neutralization-of-input-during-web-page-generation-on-id-parameter-in-wordpress-marmoset-viewer-plugin-versions-1.9.3-leads-to-reflected-cross-site-scripting/
- https://wpscan.com/vulnerability/d11b79a3-f762-49ab-b7c8-3174624d7638
- https://johnjhacking.com/blog/cve-2021-24495-improper-neutralization-of-input-during-web-page-generation-on-id-parameter-in-wordpress-marmoset-viewer-plugin-versions-1.9.3-leads-to-reflected-cross-site-scripting/
- https://wpscan.com/vulnerability/d11b79a3-f762-49ab-b7c8-3174624d7638
Get alerted when CVE-2021-24495 or the next vulnerability affects your stack