What’s Vulnerable › Vulnerabilities
CVE-2021-24496: Community Event < 1.4.8 - Reflected Cross-Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Community Events WordPress plugin before 1.4.8 does not sanitise, validate or escape its importrowscount and successimportcount GET parameters before outputting them back in an admin page, leading to a reflected Cross-Site Scripting issue which will be executed in the context of a logged in administrator
Affected products
- Community Events: before 1.4.8 — fixed in 1.4.8
How to fix
Upgrade to a fixed version: Community Events 1.4.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5fd1cb7f-a036-4c5b-9557-0ffd4ef6b834
- https://wpscan.com/vulnerability/5fd1cb7f-a036-4c5b-9557-0ffd4ef6b834
Get alerted when CVE-2021-24496 or the next vulnerability affects your stack