What’s Vulnerable › Vulnerabilities
CVE-2021-24498: Calendar Event Multi View < 1.4.01 - Unauthenticated Reflected Cross-Site Scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Calendar Event Multi View WordPress plugin before 1.4.01 does not sanitise or escape the 'start' and 'end' GET parameters before outputting them in the page (via php/edit.php), leading to a reflected Cross-Site Scripting issue.
Affected products
- Calendar Event Multi View: before 1.4.01 — fixed in 1.4.01
How to fix
Upgrade to a fixed version: Calendar Event Multi View 1.4.01. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3c5a5187-42b3-4f88-9b0e-4fdfa1c39e86
- https://wpscan.com/vulnerability/3c5a5187-42b3-4f88-9b0e-4fdfa1c39e86
Get alerted when CVE-2021-24498 or the next vulnerability affects your stack