What’s Vulnerable › Vulnerabilities
CVE-2021-24502: WP Google Map < 1.7.7 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Google Map WordPress plugin before 1.7.7 did not sanitise or escape the Map Title before outputting them in the page, leading to a Stored Cross-Site Scripting issue by high privilege users, even when the unfiltered_html capability is disallowed
Affected products
- WP Maps: before 1.7.7 — fixed in 1.7.7
How to fix
Upgrade to a fixed version: WP Maps 1.7.7. Check the vendor advisory for mitigations.
References
- https://drive.google.com/file/d/1CbBlsf0Vt1QLBTnSC-vod2UCMm_NnZ2p/view?usp=sharing
- https://wpscan.com/vulnerability/f95c3a48-5228-4047-9b92-de985741d157
- https://drive.google.com/file/d/1CbBlsf0Vt1QLBTnSC-vod2UCMm_NnZ2p/view?usp=sharing
- https://wpscan.com/vulnerability/f95c3a48-5228-4047-9b92-de985741d157
Get alerted when CVE-2021-24502 or the next vulnerability affects your stack