What’s Vulnerable › Vulnerabilities
CVE-2021-24503: Popular Brand SVG Icons - Simple Icons < 2.7.8 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The Popular Brand Icons – Simple Icons WordPress plugin before 2.7.8 does not sanitise or validate some of its shortcode parameters, such as "color", "size" or "class", allowing users with a role as low as Contributor to set Cross-Site payload in them. A post made by a contributor would still have to be approved by an admin to have the XSS triggered in the frontend, however, higher privilege users, such as editor could exploit this without the need of approval, and even when the blog disallows the unfiltered_html capability.
Affected products
- Popular Brand Icons – Simple Icons: before 2.7.8 — fixed in 2.7.8
How to fix
Upgrade to a fixed version: Popular Brand Icons – Simple Icons 2.7.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/18ab1570-2b4a-48a4-86e6-c1d368563691
- https://wpscan.com/vulnerability/18ab1570-2b4a-48a4-86e6-c1d368563691
Get alerted when CVE-2021-24503 or the next vulnerability affects your stack