What’s Vulnerable › Vulnerabilities
CVE-2021-24508: Smash Balloon Social Post Feed < 2.19.2 - Unauthenticated Stored XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Smash Balloon Social Post Feed WordPress plugin before 2.19.2 does not sanitise or escape the feedID POST parameter in its feed_locator AJAX action (available to both authenticated and unauthenticated users) before outputting a truncated version of it in the admin dashboard, leading to an unauthenticated Stored Cross-Site Scripting issue which will be executed in the context of a logged in administrator.
Affected products
- Smash Balloon Social Post Feed: before 2.19.2 — fixed in 2.19.2
How to fix
Upgrade to a fixed version: Smash Balloon Social Post Feed 2.19.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2b543740-d4b0-49b5-a021-454a3a72162f
- https://wpscan.com/vulnerability/2b543740-d4b0-49b5-a021-454a3a72162f
Get alerted when CVE-2021-24508 or the next vulnerability affects your stack