What’s Vulnerable › Vulnerabilities
CVE-2021-24514: Visual Form Builder < 3.0.4 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Visual Form Builder WordPress plugin before 3.0.4 does not sanitise or escape its Form Name, allowing high privilege users such as admin to set Cross-Site Scripting payload in them, even when the unfiltered_html capability is disallowed
Affected products
- Visual Form Builder: before 3.0.4 — fixed in 3.0.4
How to fix
Upgrade to a fixed version: Visual Form Builder 3.0.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0afa78d3-2403-4e0c-8f16-5b7874b03cd2
- https://wpscan.com/vulnerability/0afa78d3-2403-4e0c-8f16-5b7874b03cd2
Get alerted when CVE-2021-24514 or the next vulnerability affects your stack