What’s Vulnerable › Vulnerabilities
CVE-2021-24517: Stop Spammers Security < 2021.18 - Authenticated Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Stop Spammers Security | Block Spam Users, Comments, Forms WordPress plugin before 2021.18 does not escape some of its settings, allowing high privilege users such as admin to set Cross-Site Scripting payloads in them even when the unfiltered_html capability is disallowed
Affected products
- Stop Spammers Security | Block Spam Users, Comments, Forms: before 2021.18 — fixed in 2021.18
How to fix
Upgrade to a fixed version: Stop Spammers Security | Block Spam Users, Comments, Forms 2021.18. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/f440edd8-94fe-440a-8a5b-e3d24dcfcbc1
- https://wpscan.com/vulnerability/f440edd8-94fe-440a-8a5b-e3d24dcfcbc1
Get alerted when CVE-2021-24517 or the next vulnerability affects your stack