What’s Vulnerable › Vulnerabilities
CVE-2021-24518: WPFront Notification Bar < 2.0.0.07176 - Authenticated Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The WPFront Notification Bar WordPress plugin before 2.0.0.07176 does not sanitise or escape its Custom CSS setting, allowing high privilege users such as admin to set XSS payload in it even when the unfiltered_html capability is disallowed, leading to an authenticated Stored Cross-Site Scripting issue
Affected products
- Wpfront Notification Bar: before 2.0.0.07176 — fixed in 2.0.0.07176
How to fix
Upgrade to a fixed version: Wpfront Notification Bar 2.0.0.07176. Check the vendor advisory for mitigations.
References
- https://packetstormsecurity.com/files/163472/
- https://wpscan.com/vulnerability/53103cdc-a4bf-40fa-aeb1-790fc7a65f0a
- https://packetstormsecurity.com/files/163472/
- https://wpscan.com/vulnerability/53103cdc-a4bf-40fa-aeb1-790fc7a65f0a
Get alerted when CVE-2021-24518 or the next vulnerability affects your stack