What’s Vulnerable › Vulnerabilities
CVE-2021-24530: Alojapro Widget <= 1.1.15 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Alojapro Widget WordPress plugin through 1.1.15 doesn't properly sanitise its Custom CSS settings, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- Alojapro Widget: before 1.1.16 — fixed in 1.1.16
How to fix
Upgrade to a fixed version: Alojapro Widget 1.1.16. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/caf36ca5-aafd-48bd-a1e5-30f3973d8eb8
- https://wpscan.com/vulnerability/caf36ca5-aafd-48bd-a1e5-30f3973d8eb8
Get alerted when CVE-2021-24530 or the next vulnerability affects your stack