What’s Vulnerable › Vulnerabilities
CVE-2021-24533: Maintenance < 4.03 - Authenticated Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The Maintenance WordPress plugin before 4.03 does not sanitise or escape some of its settings, allowing high privilege users such as admin to se Cross-Site Scripting payload in them (even when the unfiltered_html capability is disallowed), which will be triggered in the frontend
Affected products
- Maintenance: before 4.03 — fixed in 4.03
How to fix
Upgrade to a fixed version: Maintenance 4.03. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/174b2119-b806-4da4-a23d-c19b552c86cb
- https://wpscan.com/vulnerability/174b2119-b806-4da4-a23d-c19b552c86cb
Get alerted when CVE-2021-24533 or the next vulnerability affects your stack