What’s Vulnerable › Vulnerabilities
CVE-2021-24540: Wonder Video Embed < 1.8 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Wonder Video Embed WordPress plugin before 1.8 does not escape parameters of its wonderplugin_video shortcode, which could allow users with a role as low as Contributor to perform Stored XSS attacks.
Affected products
- wonderplugin Wonder Video Embed: before 1.8 — fixed in 1.8
How to fix
Upgrade to a fixed version: wonderplugin Wonder Video Embed 1.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/67910e5d-ea93-418b-af81-c50d0e05d213
- https://wpscan.com/vulnerability/67910e5d-ea93-418b-af81-c50d0e05d213
Get alerted when CVE-2021-24540 or the next vulnerability affects your stack