What’s Vulnerable › Vulnerabilities
CVE-2021-24541: Wonder PDF Embed < 1.7 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Wonder PDF Embed WordPress plugin before 1.7 does not escape parameters of its wonderplugin_pdf shortcode, which could allow users with a role as low as Contributor to perform Stored XSS attacks.
Affected products
- Wonder PDF Embed: before 1.7 — fixed in 1.7
How to fix
Upgrade to a fixed version: Wonder PDF Embed 1.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e6602369-87f4-4454-8298-89cc69f8375c
- https://wpscan.com/vulnerability/e6602369-87f4-4454-8298-89cc69f8375c
Get alerted when CVE-2021-24541 or the next vulnerability affects your stack