What’s Vulnerable › Vulnerabilities
CVE-2021-24546: EditorsKit < 1.31.6 - Contributor+ Arbitrary PHP Code Execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-11 · updated 2026-06-17
- Weakness: CWE-94
Description
The Gutenberg Block Editor Toolkit – EditorsKit WordPress plugin before 1.31.6 does not sanitise and validate the Conditional Logic of the Custom Visibility settings, allowing users with a role as low contributor to execute Arbitrary PHP code
Affected products
- munirkamal Gutenberg Block Editor Toolkit – EditorsKit: before 1.31.6 — fixed in 1.31.6
How to fix
Upgrade to a fixed version: munirkamal Gutenberg Block Editor Toolkit – EditorsKit 1.31.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/bdc36f6a-682d-4d66-b587-92e86085d971
- https://wpscan.com/vulnerability/bdc36f6a-682d-4d66-b587-92e86085d971
Get alerted when CVE-2021-24546 or the next vulnerability affects your stack