What’s Vulnerable › Vulnerabilities
CVE-2021-24559: Qyrr < 0.7 - Authenticated (contributor+) Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The Qyrr WordPress plugin before 0.7 does not escape the data-uri of the QR Code when outputting it in a src attribute, allowing for Cross-Site Scripting attacks. Furthermore, the data_uri_to_meta AJAX action, available to all authenticated users, only had a CSRF check in place, with the nonce available to users with a role as low as Contributor allowing any user with such role (and above) to set a malicious data-uri in arbitrary QR Code posts, leading to a Stored Cross-Site Scripting issue.
Affected products
- Qyrr: before 0.7 — fixed in 0.7
How to fix
Upgrade to a fixed version: Qyrr 0.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/65a29976-163a-4bbf-a4e8-590ddc4b83f2/
- https://wpscan.com/vulnerability/65a29976-163a-4bbf-a4e8-590ddc4b83f2/
Get alerted when CVE-2021-24559 or the next vulnerability affects your stack