What’s Vulnerable › Vulnerabilities
CVE-2021-24566: WooCommerce Currency Switcher < 1.3.7 - Authenticated (Low Privilege) Local File Inclusion
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-22
Description
The WooCommerce Currency Switcher FOX WordPress plugin before 1.3.7 was vulnerable to LFI attacks via the "woocs" shortcode.
Affected products
- realmag777 FOX – Currency Switcher Professional for WooCommerce: before 1.3.7 — fixed in 1.3.7
How to fix
Upgrade to a fixed version: realmag777 FOX – Currency Switcher Professional for WooCommerce 1.3.7. Check the vendor advisory for mitigations.
References
- https://jetpack.com/2021/07/22/severe-vulnerability-patched-in-woocommerce-currency-switcher/
- https://wpscan.com/vulnerability/a0bc4b13-53fe-462d-8306-8915196d3a5a/
- https://jetpack.com/2021/07/22/severe-vulnerability-patched-in-woocommerce-currency-switcher/
- https://wpscan.com/vulnerability/a0bc4b13-53fe-462d-8306-8915196d3a5a/
Get alerted when CVE-2021-24566 or the next vulnerability affects your stack