What’s Vulnerable › Vulnerabilities
CVE-2021-24569: Cookie Notice & Compliance for GDPR / CCPA < 2.1.2 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Cookie Notice & Compliance for GDPR / CCPA WordPress plugin before 2.1.2 does not escape the value of its Button Text setting when outputting it in an attribute in the frontend, allowing high privilege users such as admin to perform Cross-Site Scripting even when the unfiltered_html capability is disallowed.
Affected products
- Cookie Notice & Compliance for GDPR / CCPA: before 2.1.2 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: Cookie Notice & Compliance for GDPR / CCPA 2.1.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/38053e05-4b17-4fa9-acd3-85d8529b202b
- https://wpscan.com/vulnerability/38053e05-4b17-4fa9-acd3-85d8529b202b
Get alerted when CVE-2021-24569 or the next vulnerability affects your stack