What’s Vulnerable › Vulnerabilities
CVE-2021-24574: Simple Banner < 2.10.4 - Authenticated Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The Simple Banner WordPress plugin before 2.10.4 does not sanitise and escape one of its settings, allowing high privilege users such as admin to use Cross-Site Scripting payload even when the unfiltered_html capability is disallowed.
Affected products
- Simple Banner: before 2.10.4 — fixed in 2.10.4
How to fix
Upgrade to a fixed version: Simple Banner 2.10.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2571047/
- https://wpscan.com/vulnerability/9adf7022-5108-43b7-bf0e-a42593185b74
- https://plugins.trac.wordpress.org/changeset/2571047/
- https://wpscan.com/vulnerability/9adf7022-5108-43b7-bf0e-a42593185b74
Get alerted when CVE-2021-24574 or the next vulnerability affects your stack