What’s Vulnerable › Vulnerabilities
CVE-2021-24579: Bold Page Builder < 3.1.6 - PHP Object Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-30 · updated 2026-06-17
- Weakness: CWE-502
Description
The bt_bb_get_grid AJAX action of the Bold Page Builder WordPress plugin before 3.1.6 passes user input into the unserialize() function without any validation or sanitisation, which could lead to a PHP Object Injection. Even though the plugin did not contain a suitable gadget to fully exploit the issue, other installed plugins on the blog could allow such issue to be exploited and lead to RCE in some cases.
Affected products
- boldthemes Bold Page Builder: before 3.1.6 — fixed in 3.1.6
How to fix
Upgrade to a fixed version: boldthemes Bold Page Builder 3.1.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/08edce3f-2746-4886-8439-76e44ec76fa8
- https://wpscan.com/vulnerability/08edce3f-2746-4886-8439-76e44ec76fa8
Get alerted when CVE-2021-24579 or the next vulnerability affects your stack