What’s Vulnerable › Vulnerabilities
CVE-2021-24580: Side Menu Lite < 2.2.6 - Authenticated SQL Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-30 · updated 2026-06-17
- Weakness: CWE-89
Description
The Side Menu Lite WordPress plugin before 2.2.6 does not sanitise user input from the List page in the admin dashboard before using it in SQL statement, leading to a SQL Injection issue
Affected products
- Side Menu Lite – add sticky fixed buttons: before 2.2.6 — fixed in 2.2.6
How to fix
Upgrade to a fixed version: Side Menu Lite – add sticky fixed buttons 2.2.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2faccd1b-4b1c-4b3e-b917-de2d05e860f8
- https://wpscan.com/vulnerability/2faccd1b-4b1c-4b3e-b917-de2d05e860f8
Get alerted when CVE-2021-24580 or the next vulnerability affects your stack