What’s Vulnerable › Vulnerabilities
CVE-2021-24582: ThinkTwit < 1.7.1 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The ThinkTwit WordPress plugin before 1.7.1 did not sanitise or escape its "Consumer key" setting before outputting it its settings page, leading to a Stored Cross-Site Scripting issue.
Affected products
- ThinkTwit: before 1.7.1 — fixed in 1.7.1
How to fix
Upgrade to a fixed version: ThinkTwit 1.7.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5a5293ed-ddcb-4a63-9420-09942e7d69c2
- https://wpscan.com/vulnerability/5a5293ed-ddcb-4a63-9420-09942e7d69c2
Get alerted when CVE-2021-24582 or the next vulnerability affects your stack