What’s Vulnerable › Vulnerabilities
CVE-2021-24587: Splash Header < 1.20.8 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Splash Header WordPress plugin before 1.20.8 doesn't sanitise and escape some of its settings while outputting them in the admin dashboard, leading to an authenticated Stored Cross-Site Scripting issue.
Affected products
- Splash Header: before 1.20.8 — fixed in 1.20.8
How to fix
Upgrade to a fixed version: Splash Header 1.20.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/bb5d94ad-e1ce-44e2-8403-d73fe75a146a
- https://wpscan.com/vulnerability/bb5d94ad-e1ce-44e2-8403-d73fe75a146a
Get alerted when CVE-2021-24587 or the next vulnerability affects your stack