What’s Vulnerable › Vulnerabilities
CVE-2021-24588: SMS Alert Order Notifications – WooCommerce < 3.4.7 Authenticated Cross Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The SMS Alert Order Notifications WordPress plugin before 3.4.7 is affected by a cross site scripting (XSS) vulnerability in the plugin's setting page.
Affected products
- cozyvision1 SMS Alert – SMS & OTP for WooCommerce, Order Notifications & Abandoned Cart Recovery: before 3.4.7 — fixed in 3.4.7
How to fix
Upgrade to a fixed version: cozyvision1 SMS Alert – SMS & OTP for WooCommerce, Order Notifications & Abandoned Cart Recovery 3.4.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/dc2ce546-9da1-442c-8ee2-cd660634501f
- https://wpscan.com/vulnerability/dc2ce546-9da1-442c-8ee2-cd660634501f
Get alerted when CVE-2021-24588 or the next vulnerability affects your stack