What’s Vulnerable › Vulnerabilities
CVE-2021-24591: Highlight < 0.9.3 - Authenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Highlight WordPress plugin before 0.9.3 does not sanitise its CustomCSS setting, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- Highlight: before 0.9.3 — fixed in 0.9.3
How to fix
Upgrade to a fixed version: Highlight 0.9.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c5cbe3b4-2829-4fd2-8194-4b3a2ae0e257
- https://wpscan.com/vulnerability/c5cbe3b4-2829-4fd2-8194-4b3a2ae0e257
Get alerted when CVE-2021-24591 or the next vulnerability affects your stack