What’s Vulnerable › Vulnerabilities
CVE-2021-24592: Sitewide Notice WP < 2.3 - Authenticated Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The Sitewide Notice WP WordPress plugin before 2.3 does not sanitise some of its settings before outputting them in frontend pages, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- Sitewide Notice WP: before 2.3 — fixed in 2.3
How to fix
Upgrade to a fixed version: Sitewide Notice WP 2.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9579ff13-9597-4a77-8cb9-997e35265d22
- https://wpscan.com/vulnerability/9579ff13-9597-4a77-8cb9-997e35265d22
Get alerted when CVE-2021-24592 or the next vulnerability affects your stack