What’s Vulnerable › Vulnerabilities
CVE-2021-24593: Business Hours Indicator < 2.3.5 - Authenticated Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The Business Hours Indicator WordPress plugin before 2.3.5 does not sanitise or escape its 'Now closed message" setting when outputting it in the backend and frontend, leading to an Authenticated Stored Cross-Site Scripting issue
Affected products
- Business Hours Indicator: before 2.3.5 — fixed in 2.3.5
How to fix
Upgrade to a fixed version: Business Hours Indicator 2.3.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/309296d4-c397-4fc7-85fb-a28b5b5b6a8d
- https://wpscan.com/vulnerability/309296d4-c397-4fc7-85fb-a28b5b5b6a8d
Get alerted when CVE-2021-24593 or the next vulnerability affects your stack