What’s Vulnerable › Vulnerabilities
CVE-2021-24594: Translate WordPress - Google Language Translator < 6.0.12 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The Translate WordPress – Google Language Translator WordPress plugin before 6.0.12 does not sanitise and escape some of its settings before outputting it in various pages, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- Translate WordPress – Google Language Translator: before 6.0.12 — fixed in 6.0.12
How to fix
Upgrade to a fixed version: Translate WordPress – Google Language Translator 6.0.12. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2607480/
- https://wpscan.com/vulnerability/cf7b0f07-8b9b-40a1-ba7b-e8d34f515a6b
- https://plugins.trac.wordpress.org/changeset/2607480/
- https://wpscan.com/vulnerability/cf7b0f07-8b9b-40a1-ba7b-e8d34f515a6b
Get alerted when CVE-2021-24594 or the next vulnerability affects your stack