What’s Vulnerable › Vulnerabilities
CVE-2021-24598: Testimonial Builder < 1.6.0 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The Testimonial WordPress plugin before 1.6.0 does not escape some testimonial fields which could allow high privilege users to perform Cross Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- Testimonial: before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: Testimonial 1.6.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2606523/
- https://wpscan.com/vulnerability/365c09a7-0b10-4145-a415-5c0e9f429ae0
- https://plugins.trac.wordpress.org/changeset/2606523/
- https://wpscan.com/vulnerability/365c09a7-0b10-4145-a415-5c0e9f429ae0
Get alerted when CVE-2021-24598 or the next vulnerability affects your stack