What’s Vulnerable › Vulnerabilities
CVE-2021-24599: Email Encoder < 2.1.2 - Reflected Cross Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Email Encoder – Protect Email Addresses WordPress plugin before 2.1.2 has an endpoint that requires no authentication and will render a user supplied value in the HTML response without escaping or sanitizing the data.
Affected products
- Email Encoder: before 2.1.2 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: Email Encoder 2.1.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/625a272f-5c69-4f6a-8eee-32f70cd4a558
- https://wpscan.com/vulnerability/625a272f-5c69-4f6a-8eee-32f70cd4a558
Get alerted when CVE-2021-24599 or the next vulnerability affects your stack