What’s Vulnerable › Vulnerabilities
CVE-2021-24601: WPFront Notification Bar < 2.1.0.08087 - Authenticated Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The WPFront Notification Bar WordPress plugin before 2.1.0.08087 does not properly sanitise and escape its settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- syammohanm WPFront Notification Bar: before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: syammohanm WPFront Notification Bar 2.1.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/bb437706-a918-4d66-b027-b083ab486074
- https://wpscan.com/vulnerability/bb437706-a918-4d66-b027-b083ab486074
Get alerted when CVE-2021-24601 or the next vulnerability affects your stack