What’s Vulnerable › Vulnerabilities
CVE-2021-24604: Availability Calendar < 1.2.2 - Authenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Availability Calendar WordPress plugin before 1.2.2 does not sanitise or escape its Category Names before outputting them in page/post where the associated shortcode is embed, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed
Affected products
- Availability Calendar: before 1.2.2 — fixed in 1.2.2
How to fix
Upgrade to a fixed version: Availability Calendar 1.2.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d084c5b1-45f1-4e7e-b3e9-3c98ae4bce9c
- https://wpscan.com/vulnerability/d084c5b1-45f1-4e7e-b3e9-3c98ae4bce9c
Get alerted when CVE-2021-24604 or the next vulnerability affects your stack