What’s Vulnerable › Vulnerabilities
CVE-2021-24610: TranslatePress < 2.0.9 - Authenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The TranslatePress WordPress plugin before 2.0.9 does not implement a proper sanitisation on the translated strings. The 'trp_sanitize_string' function only removes script tag with a regex, still allowing other HTML tags and attributes to execute javascript, which could lead to authenticated Stored Cross-Site Scripting issues.
Affected products
- Cozmoslabs TranslatePress: before 2.0.9 — fixed in 2.0.9
How to fix
Upgrade to a fixed version: Cozmoslabs TranslatePress 2.0.9. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/164306/WordPress-TranslatePress-2.0.8-Cross-Site-Scripting.html
- https://wpscan.com/vulnerability/b87fcc2f-c2eb-4e23-9757-d1c590f26d3f
- http://packetstormsecurity.com/files/164306/WordPress-TranslatePress-2.0.8-Cross-Site-Scripting.html
- https://wpscan.com/vulnerability/b87fcc2f-c2eb-4e23-9757-d1c590f26d3f
Get alerted when CVE-2021-24610 or the next vulnerability affects your stack