What’s Vulnerable › Vulnerabilities
CVE-2021-24613: Post Views Counter < 1.3.5 - Authenticated Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Post Views Counter WordPress plugin before 1.3.5 does not sanitise or escape its Post Views Label settings, which could allow high privilege users to perform Cross-Site Scripting attacks in the frontend even when the unfiltered_html capability is disallowed
Affected products
- dFactory Post Views Counter: before 1.3.5 — fixed in 1.3.5
How to fix
Upgrade to a fixed version: dFactory Post Views Counter 1.3.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0b8c5947-bc73-448e-8f10-a4f4456e4000
- https://wpscan.com/vulnerability/0b8c5947-bc73-448e-8f10-a4f4456e4000
Get alerted when CVE-2021-24613 or the next vulnerability affects your stack