What’s Vulnerable › Vulnerabilities
CVE-2021-24614: Book appointment Online < 1.39 - Authenticated Stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Book appointment online WordPress plugin before 1.39 does not sanitise or escape Service Prices before outputting it in the List, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- Book appointment online: before 1.39 — fixed in 1.39
How to fix
Upgrade to a fixed version: Book appointment online 1.39. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e8b5c609-dc67-4dce-b6bb-7d63c0c2a014
- https://wpscan.com/vulnerability/e8b5c609-dc67-4dce-b6bb-7d63c0c2a014
Get alerted when CVE-2021-24614 or the next vulnerability affects your stack