What’s Vulnerable › Vulnerabilities
CVE-2021-24618: Donate With QRCode < 1.4.5 - Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Donate With QRCode WordPress plugin before 1.4.5 does not sanitise or escape its QRCode Image setting, which result into a Stored Cross-Site Scripting (XSS). Furthermore, the plugin also does not have any CSRF and capability checks in place when saving such setting, allowing any authenticated user (as low as subscriber), or unauthenticated user via a CSRF vector to update them and perform such attack.
Affected products
- Donate With QRCode: before 1.4.5 — fixed in 1.4.5
How to fix
Upgrade to a fixed version: Donate With QRCode 1.4.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d50b801a-16b5-45e9-a465-e3bb0445cb49
- https://wpscan.com/vulnerability/d50b801a-16b5-45e9-a465-e3bb0445cb49
Get alerted when CVE-2021-24618 or the next vulnerability affects your stack