What’s Vulnerable › Vulnerabilities
CVE-2021-24621: WP Courses LMS < 2.0.44 - Authenticated Stored XSS via Video Embed Code
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Courses LMS WordPress plugin before 2.0.44 does not sanitise its Video Embed Code, allowing malicious code to be injected in it by high privilege users, even when the unfiltered_html capability is disallowed, which could lead to Stored Cross-Site Scripting issues
Affected products
- WP Courses LMS: before 2.0.44 — fixed in 2.0.44
How to fix
Upgrade to a fixed version: WP Courses LMS 2.0.44. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/bfbb32ac-9ef9-46de-8e5e-7d6d6fb868d8
- https://wpscan.com/vulnerability/bfbb32ac-9ef9-46de-8e5e-7d6d6fb868d8
Get alerted when CVE-2021-24621 or the next vulnerability affects your stack