What’s Vulnerable › Vulnerabilities
CVE-2021-24636: Print My Blog < 3.4.2 - Plugin Deactivation via CSRF
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-20 · updated 2026-06-17
- Weakness: CWE-352
Description
The Print My Blog WordPress Plugin before 3.4.2 does not enforce nonce (CSRF) checks, which allows attackers to make logged in administrators deactivate the Print My Blog plugin and delete all saved data for that plugin by tricking them to open a malicious link
Affected products
- Michael Nelson Print My Blog: before 3.4.2 — fixed in 3.4.2
How to fix
Upgrade to a fixed version: Michael Nelson Print My Blog 3.4.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/db8ace7b-7a44-4620-9fe8-ddf0ad520f5e
- https://wpscan.com/vulnerability/db8ace7b-7a44-4620-9fe8-ddf0ad520f5e
Get alerted when CVE-2021-24636 or the next vulnerability affects your stack